[Bug Report] Titan Simulator fails to launch

For anything that doesn't belong in the other boards

Moderator: Moderators

mynameisyz
Posts: 3
Joined: 07 Aug 2019, 16:30

[Bug Report] Titan Simulator fails to launch

Postby mynameisyz » 21 Nov 2019, 16:38

Hi all,

As per title, Titan Simulator fails to launch. This happens on v11.x and v12.

I have attached the log file for your pleasure. Looks like you guys missed a quotation mark character in GetURL().

Regards

Code: Select all

<E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent"><System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system"><EventID>0</EventID><Type>3</Type><SubType Name="Verbose">0</SubType><Level>16</Level><TimeCreated SystemTime="2019-11-21T16:19:30.7039368Z" /><Source Name="General" /><Correlation ActivityID="{00000000-0000-0000-0000-000000000000}" /><Execution ProcessName="TitanSimulator" ProcessID="9872" ThreadID="1" /><Channel/><Computer>DESKTOP-ILEM871</Computer></System><ApplicationData><TraceData><DataItem><XmlLogEntry><Xml /><Message>STARTING - Constructing Show Controller</Message><Categories><String>General</String></Categories><Priority>-1</Priority><EventId>0</EventId><Severity>Verbose</Severity><LoggedSeverity>Verbose</LoggedSeverity><Title>Avolites.General.ExceptionHandling.AvoLifecycleLogEntry</Title><TimeStamp>21/11/2019 4:19:30 PM</TimeStamp><MachineName>DESKTOP-ILEM871</MachineName><AppDomainName>TitanSimulator.exe</AppDomainName><ProcessId>9872</ProcessId><ProcessName>C:\Program Files (x86)\Avolites\Titan Simulator\TitanSimulator.exe</ProcessName><ManagedThreadName /><Win32ThreadId>9876</Win32ThreadId><ExtendedProperties><KeyValuePair_2><Key>exceptionType</Key><Value>Avolites.General.ExceptionHandling.AvoLifecycleLogEntry</Value></KeyValuePair_2><KeyValuePair_2><Key>softwareVersion</Key><Value>12.0.108.5</Value></KeyValuePair_2><KeyValuePair_2><Key>EventType</Key><Value>Start</Value></KeyValuePair_2></ExtendedProperties><TimeStampString>21/11/2019 4:19:30 PM</TimeStampString><ActivityId>00000000-0000-0000-0000-000000000000</ActivityId><RelatedActivityId /><ErrorMessages /><ActivityIdString>00000000-0000-0000-0000-000000000000</ActivityIdString><CategoriesStrings><String>General</String></CategoriesStrings></XmlLogEntry></DataItem></TraceData></ApplicationData></E2ETraceEvent><E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent"><System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system"><EventID>0</EventID><Type>3</Type><SubType Name="Critical">0</SubType><Level>1</Level><TimeCreated SystemTime="2019-11-21T16:19:31.1386785Z" /><Source Name="General" /><Correlation ActivityID="{00000000-0000-0000-0000-000000000000}" /><Execution ProcessName="TitanSimulator" ProcessID="9872" ThreadID="1" /><Channel/><Computer>DESKTOP-ILEM871</Computer></System><ApplicationData><TraceData><DataItem><XmlLogEntry><Xml /><Message>Compliation of action script failed:
ActionScript.GetURL("http://192.168.1.111:3000)
Errors:
20: Unexpected token '' found. Expected CLOSEBRACKET
20: Unexpected token '' found. Expected EOF</Message><Categories><String>General</String></Categories><Priority>-1</Priority><EventId>0</EventId><Severity>Critical</Severity><LoggedSeverity>Critical</LoggedSeverity><Title>Avolites.Menus.AvoActionScriptException</Title><TimeStamp>21/11/2019 4:19:31 PM</TimeStamp><MachineName>DESKTOP-ILEM871</MachineName><AppDomainName>TitanSimulator.exe</AppDomainName><ProcessId>9872</ProcessId><ProcessName>C:\Program Files (x86)\Avolites\Titan Simulator\TitanSimulator.exe</ProcessName><ManagedThreadName /><Win32ThreadId>9876</Win32ThreadId><ExtendedProperties><KeyValuePair_2><Key>exceptionType</Key><Value>Avolites.Menus.AvoActionScriptException</Value></KeyValuePair_2><KeyValuePair_2><Key>stackTrace</Key><Value>   at Avolites.Menus.MenuAction.Compile()
   at Avolites.Menus.MenuAction.LoadXml(XmlNode node, MenuLanguage language)
   at Avolites.Menus.Macros.Macro.LoadXml(XmlNode node, MenuLanguage language)
   at Avolites.Titan.Controllers.UserMacro.LoadOldXml(XmlNode xml, MenuManager menu, Boolean loadMacro, Int32&amp; userNumber, Int32&amp; iconId, Macro&amp; macro)
   at Avolites.Titan.Controllers.UserMacroController.LoadMacro(FileInfo macroFile)
   at Avolites.Titan.Controllers.UserMacroController.LoadLibrary(String macroLibraryPath)
   at Avolites.Titan.Controllers.UserMacroController.LoadLibrary()
   at Avolites.Titan.Controllers.UserMacroController..ctor(MenuManager menu, HandleController handleController, IconController icons, ShowController show)
   at Avolites.Titan.Controllers.PanelManagerBase.CreateUserMacroController()
   at Avolites.Console.ConsolePanelManager.InitialiseControllers()
   at Avolites.Sapphire.PanelManager.Start()</Value></KeyValuePair_2><KeyValuePair_2><Key>exceptionSource</Key><Value>Avolites.Menus</Value></KeyValuePair_2><KeyValuePair_2><Key>targetSite</Key><Value>Void Compile()</Value></KeyValuePair_2><KeyValuePair_2><Key>softwareVersion</Key><Value>12.0.108.5</Value></KeyValuePair_2></ExtendedProperties><TimeStampString>21/11/2019 4:19:31 PM</TimeStampString><ActivityId>00000000-0000-0000-0000-000000000000</ActivityId><RelatedActivityId /><ErrorMessages /><ActivityIdString>00000000-0000-0000-0000-000000000000</ActivityIdString><CategoriesStrings><String>General</String></CategoriesStrings></XmlLogEntry></DataItem></TraceData></ApplicationData></E2ETraceEvent>
User avatar
Gregory
Site Admin
Posts: 1145
Joined: 14 Dec 2007, 15:25
Location: London, United Kingdom
Contact:

Re: [Bug Report] Titan Simulator fails to launch

Postby Gregory » 26 Nov 2019, 01:47

It looks like the parse error was while loading a macro. Do you have any custom macros installed?
mynameisyz
Posts: 3
Joined: 07 Aug 2019, 16:30

Re: [Bug Report] Titan Simulator fails to launch

Postby mynameisyz » 26 Nov 2019, 14:36

Yes you're right!

Simulator works now after removing the custom macros that i've been experimenting with.

Though I'm a little surprised that a badly written macro could halt the software launch.

Thanks! You have been a great help!

Who is online

Users browsing this forum: No registered users and 0 guests