Page 1 of 1

Personality Builder will not open Titan 4.1

Posted: 17 May 2011, 13:18
by iadwm
So the first 'real' time I go to use Personality Builder (on the Pearl) and it doesn't work !...

Just updated Titan from 4 to 4.1 and Personality Builder (according to About..) is 2.1

The program doesn't open and I get this..
" The condition 'Else' in 'Colour1' does not exist . This ID will be removed from the condition, this may cause other invalid references"

Press OK to close the box did nothing

This also prevented the desk from Shutting down and I had top pull the plug

I only wanted to make a change to the Martin Wizard Extreme personality, about a year ago (perhaps 2!) I wanted the Shutter to appear/work on the Dimmer channel, but was told that this wouldn't work at that time, because Titan could only use one HTP attribute.
Has this changed now?
Will the change to the personality file work ?



Posted: 17 May 2011, 13:38
by niclights
It does work.

Whatever file it was trying to open had the reported error. But it should continue past any errors simply removing them as it states.

In this case I wonder if, after pressing 'ok', the Titan windows took focus and you could no longer see the builder. You can use tools/switch task to find any applications that might be hidden. In extreme circumstances you might get a hung process and need open Task Manager with ctrl+shift+esc and close it manually.

Titan can only have one HTP attribute per fixture but that's really only a problem with RGB. Here it should be fine.

Note that this file was last updated 31/01/11. Make sure your library is up-to-date. Personalities are added and updated daily.

Go to Wheel Mapping view and drag into dimmer.

/edit: I noticed an error with this file where the 8ch option with throw an error on fixture selection due to a wheel mapping mistake. I will check and fix.

Posted: 17 May 2011, 14:20
by iadwm
Hi Nic,

Still no joy, there is a loading Templates window behind the Conditions window, this freezes.

Also, The Function ID number increases Evey time I try to close the conditions box.

Calling Task Manager, just gives a blank screen and cursor ie no task manager.
(I closed all window views). Desk seems to be working and outputting ok. But I couldn't recover the display , shutdown didn't work again, loaded my show back ok, but still no external display at all, pulled the plug again.

Back to normal.

I am using the latest Fixture Library and I recall seeing the desk display an "attribute error" when I selected the Wizards. To be honest I can't remember which one using I did try a few...


Posted: 17 May 2011, 16:06
by niclights
I can't find any problem launching builder from a fresh 4.1 recovery CD install although it simply sounds like it is trying to load a file that has lots of errors and you need to go through all of them first. The ID number increasing is probably correct as it is reporting invalid values but it shouldn't go on forever.

Regarding blank screen it is important you use ctrl+shift+esc to access Task Manager. Ctrl+Alt+Del will take you to a different screen which is (AFAIK) only visible on the touch screen. But if you do accidentally do this just press Esc to cancel and get back to Titan.

Persevere with pressing ok on the errors. If this really doesn't work then you can probably manually tell it to open with a new file but I can't remember where this setting is stored. Or reinstall builder.

Posted: 17 May 2011, 18:39
by iadwm
I hadn't read the ctrl+shift+esc(is that in some notes somewhere?) and was using +del, so I'll give the +esc a go...

And perhaps re-install just Builder.



Posted: 17 May 2011, 18:44
by niclights
It was in my post above ;)

I think it changed since Windows Vista. Del gives security options.

Posted: 17 May 2011, 19:57
by iadwm
Getting there...

Yes, your post was where I read it ! However, still not getting Task manager to appear with ctrl+shift+esc, BUT esc does bring back Titan.

That were right to keep selecting No, after many (..many) selections (around 20 presses - it went through to Gobo2, so a badly corrupted file) it finally launched PB, there were a three files listed and it was set to Load Previous on start up, clearly what the problem was , I as you said originally.

Loaded with Wizard file and got shutter into Dimmer and Save.

Seems ok on the desk, but nothing in Visualiser, went back to PBuidler to generate the R20 and got a whole load of save problems, regarding Control attribute for Macros, got a warning that the file wasn't suitable for Visualiser...

I'm using Wizard Extreme 8bit, as it's driving Wizards and Wizard Extremes...

Still can't get it in Vis - any thoughts?



Posted: 17 May 2011, 23:29
by niclights
I meant my first post. But that is getting silly.
I can't explain why it doesn't bring up Task Manager. Sometimes it is necessary to get keyboard focus by pressing Esc first. But if ctrl+shift+esc blacks out the screen then I'm lost.

It's not necessarily a badly corrupted file when that happens and it might not even matter. It all depends....

I would have to look to see about Vis but it's obviously not inconceivable that it doesn't work because it no longer matches the fixture correctly. All relatively easy to solve though. Will try and look tomorrow.

Regarding saving r20's you need to check the Pearl wheel mapping (tab at the top of the wheel mapping view). The r20 mapping is not stored within the d4 file so unless all the attributes happen to land in non-conflicting default locations you must reallocate them. It's either that or you separately import the r20 file and work from there. However, assuming the option is enabled, when you save d4 files from the builder it will write a separate file that contains the r20 mapping and this will load automatically next time you edit the d4 file. So you only ever have to do this once.

Finally, sometimes you will get warnings about macros that use attributes not included in the mode. This can easily happen because macros are global, rather than individual to modes. It is just letting you know that there might not be any point in writing the macros for that particular mode and gives you the option to leave/remove.